Still having issues with TV Shows

I wasnt sure if I should have created a new topic but did so anyway, apologies if I shouldn’t have done so…

I watched a title called ‘Wish Upon (2017)’, this was in my watchlist prior to starting.

I watched the movie and then rated it when the Trakt rating notification appeared and I rated as I normally would.

Now Moviebase has removed the movie from my watchlist - great!

The movie is showing in the ‘Ratings’ section and shows as rated but it is not in my ‘History’ section.

I had the same problem yesterday, with a different title.

Trakt information is correct, Moviebase seems to be the problem, see pics below;

I think this problem, only occurs when you manually sync with Trakt. It seems like the automatic sync, when you start/open Moviebase, doesn’t cause the issue to occur but I’ll keep an eye on it this evening and tomorrow, I’ll then update this post…

Problem happens with both auto sync and manual sync and only seems to affect movies…

If I can avoid syncing for 4 hours or more, the problem doesnt happen but it is difficult to avoid as I use the app regularly. If you require further information, let me know and I’ll try to help.

It seems to be happening with all movies, today it is ‘Would You Rather’ (see pic below);

Moviebase Screen (sync removes title as watched);

Trakt Screen (shows it as watched and rated);

Anyone else having these issues?

I may have a temporary fix for now;

Add the title again, as watched. You should then have the title on Trakt website, showing as viewed twice.

Go in to your History (Trakt Website) and remove one of them. You must do this within the History section and not within the movie details. Remove by clicking the tick (watched) and the next time Moviebase syncs, it should be fine.

This will only resolve the issue for that title, so you’ll need to do this with each title which has the problem. It seems to be every movie I watch, a pain…

[Update] Well! This did work but not anymore…

Thanks. I will check this issue as soon as possible.

Thanks, have a good Christmas!

1 Like

I tried again, I got the movies to remain within Moviebase. The only difference was that I disconnected my Twitter account within Trakt. I very much doubt this would make any difference but I’ve seen stranger things occur. I’ll test tonight and keep my Twitter account disconnected and update you further.

Well! How odd! I just watched a movie and I had no issues whatsoever, everything tracked as it should have.

The only difference is that my Twitter account is no longer linked but why?

[UPDATE] I’ve just watched another movie and all is fine. So, it definitely has something to do with Twitter intergration :confused:

I just tested the History sync. The sync looks fine, but I found something weird in Trakt.

Do you have 2 Trakt accounts, which are connected to Twitter?

Because when I log in with my second Trakt account and I connect this account to Twitter then it uses the lists of my first account. In the settings, it shows the nickname from the first account very shorty and switches the normal name back.


  • Account A is connected with Twitter
  • Account B is not connected yet
  • Now, connect account B to the same Twitter account
  • In account B it shows the lists of account A.

Do you have the same problem?

No, only one account here. However, I have previously deleted my account and setup a new one, using the same username and email address.

Trakt advised me to do this, it was easier to start a fresh by doing this.

Trakt said that all the information from my previous account is anonymised and is no longer linked to an account. I have queried this before because i had many issues with titles appearing in Moviebase which i did not add. In fact, i think i raised these problems here in the forums.

When i needed to start fresh due to these problems, i changed my email address to an unused one, deleted the account and setup a new with my usual email address. I kept the username the same. The issues seemed to go away until now.

I made contact with Trakt and they said that the old data is anonymised and it is not linked to any account. I ended up believing them until you just replied. I have a feeling that the old data is still linked in some way, it has to be. I could be wrong but the history of problems point to the old supposedly, anonymised data.

I’ll see if I can find the old forum topics here and highlight them for you…

As my account isn’t currently connected, I’ll delete the authorisation from within Twitter. I’ll then reconnect a new authorisation from Trakt -to- Twitter and test. …


So, my Twitter account was previously disconnected on Trakt. I then went in to the Twitter settings and ‘revoked’ the authorisation so Trakt was in no way connected and previous authorisation was revoked/deleted. I then linked my Twitter account to Trakt, a new authorisation.

Ive just watched a movie and it looks like the above procedure has resolved the issue. I will monitor over the next few days and provide an update. :crossed_fingers:

As you know, I disconnected my Twitter account within Trakt. I also went in to my Twitter account and deleted the authorisation for Trakt within the ‘Apps and Sessions’ section. My thinking was that my old Trakt account (deleted) was somehow interfering and as the authorisation was given via my old Trakt, it wasn’t setup with the new account and this was somehow causing the issues. Once that was all deleted, I then linked Twitter to my Trakt account, so it was using the new authorisation.

Anyway, I watched a movie yesterday and all was fine.
I’ve just watched another movie and all seems fine again. So, the issue may be resolved. If the problem returns, I’ll update this post but :crossed_fingers:

I hope you understood what I was trying to sat, thanks for your time. Let’s hope this is now resolved… Have a Great New Year '20

Looks like the issue has resolved.

The Twitter Authorisation for Trakt must have been causing the issue and deleting it and completing a new authorisation must have resolved this problem.

I suspect that the Trakt data is still, in some way linked, despite Trakt C/S saying that the data is anonymised, I suspected, for a long time that this data is still somehow linked because of all the other issues I’ve had.

So, thanks for your time @chris. I hope the issues do not return.

Have a great New Year '20 :+1:

@chris [UPDATE]

Ah well! A few days without any problems and today I get a title added to my watchlist! What the hell is it with Ricky Gervais, I DONT WANT TO WATCH YOU! HaHa!

The title added was ‘Golden Years (1991)’

This title has appeared before, along with ‘After Life (2019)’.

I’ve gone to trakt website and removed it and it has gone but it is only a matter of time before HE returns! Aarrgghh! Oh! I tried removing via Moviebase but it kept coming back upon sync! Driving me NUTS!

It is rather odd that it seems to be only me with the problems…

@chris [UPDATE]

Well, another title has appeared in my watchlist, this time it is;

‘Love Story (US)’

However, I go to my watchlist via the Trakt website and ‘Love Story (US)’ is NOT in my watchlist. After looking through my watchlist, ‘Love Story (US)’ is showing as ‘Golden Years’. :strange:

I searched on the Trakt website for ‘Love Story (US)’ but nothing shows up. I then searched for ‘Golden Years’ and it shows up and is marked as in my watchlist :strange:

So, Moviebase is showing ‘Love Story (US)’ in my watchlist but on the Trakt website it shows as ‘Golden Years (2003)’. I have no idea why but all I do know is that I didnt add either of them!

I’ll attach the pics below for cross-reference purposes;

[UPDATE] I deleted the title when i last posted via the Trakt website and all has been okay.

Today it has returned within Moviebase, show is ‘Love Story (US)’ but when I view my watchlist on the Trakt website, it is called ‘Golden Years’.

So I can remove it but it will return after a week…


Thanks for the comments :slight_smile: Maybe some cached issue? :frowning: Do you still have the problem with a lot of movies?

There is a a new beta version :wink:

Definitely not a cache issue because these titles do not relate to me nor have they been added to any of the programs I use.

Trakt said they’ll look in to this but they’ve gone quiet on me, this makes me suspect that the issue is with them but that is me speculating.

I believe it has something to do with my old account but Trakt said this isn’t possible because the old data is anonymised and not linked in any way - I think it is.