Missing Trakt account link

Hi, I’m a Trakt user looking for a great user-friendly Trakt mobile client. Moviebase seemed to fit the bill, so I downloaded it (version 2.5.4) and am now a paying subscriber.

But I can’t figure out how to link my Moviebase account to my Trakt account. Where do I go to link the two so that Moviebase can see and edit my activity already recorded in Trakt? (In Moviebase’s FAQ there is a section titled “How can I connect to Trakt?” but it doesn’t seem to answer this question at all.) I’ve looked everywhere in the app but maybe I missed this feature? Or maybe I misunderstood how Moviebase works with Trakt?

Any clarification or help would be appreciated. Thank you.

at the moment it’s not possible better if u log in with ur trakt account

Ok, I thought Trakt & Moviebase worked together but I guess I was misinformed. Thanks anyway for clarifying. I will search for another service to link with Trakt.

yes they work together u can use moviebase to sign in ur trakt account

I figured it out.

If anyone else out there is trying to link Trakt & Moviebase accounts, the secret for me was to log out of then completely remove the Moviebase app from my phone. Once I reinstalled, rather than signing back in with my Moviebase account, I poked through the settings menu until I found the option to login with a third-party service (Trakt or TMDB). That’s how I was finally able to get into Moviebase via my Trakt account. Not very intuitive (and not clearly explained anywhere) but it does appear to work as I had hoped, providing two-way sync between the accounts.

Moviebase’s interface seems nicer than other Trakt clients. Now if only it had a real recommendation engine based on my watch history and interests… :slight_smile:

It is only possible to login via Google or connect to another service. You have to logout the Google account before connect to Trakt.
Both accounts are separated (will be merged in the future).

All right, I give-up! I’m not finding anywhere in Settings the option to login with a third-party service. When not signed-in, there’s a “Connect to service” button, but it doesn’t do anything except put up a notification that it would create a separate profile in the app. I’m tearing my hair out! EXACTLY what is the path to connect to Trakt in Settings, please? (This is a user-interface nightmare!)

You have to click on “Connect with Trakt”.

I created the Trakt profile a few years ago and the Google/Moviebase login in the last month.
The login is still in progress, which doesn’t have all features at the moment.

To repeat what I said in my post, “When not signed-in, there’s a ‘Connect to service’ button, but it doesn’t do anything except put up a notification that it would create a separate profile in the app.”
But your screenshot (thanks for that!) homed-in on my problem: my screen did not display the “Connect to Trakt” and “Connect to TMDb” directly under that notification. (You must have thought I am blind!) So my first instinct was to drag-upward on that notification, and low and behold, the two hidden Connect-to’s pulled-up into view. (Not exactly intuitive; without first seeing your screenshot, I wouldn’t have thought of that in a million years.)

That solved my first problem, but now that only confronted me with a second problem: choosing either of the two Connect-to’s brings up a screen that says, “You are offline” with an orange “Retry” button, which when chosen only brings up the same screen again indefinitely. I don’t know what it means by “offline,” but my Wi-Fi connection reamains uninterrupted, for whatever that”s worth… Now what?

Thanks for your explanation. It seems to be a device or Android version failure.

Which device and Android version do you use?

Do you use a proxy or indian service provider (this is blocking TMDB content)?

Not using a proxy or Indian ISP, but all along have been on a VPN with exit server in the Netherlands, which I ruled-out by trying with it disabled, but, alas, same symptoms. Next, I anticipated that my AdGuard DNS might have been the culprit, so I changed my DNS IP address to Google’s DNS (8.8.8.8), but no joy.

Next, I’ve been trying to avoid up until now to divulge that I’m on an Nvidia Shield TV box (2017) with its firmware the current 8.2.0 (Android TV OS 9.0 “Pie”). I’ve been dodging because I know what you’ll probably say: that Moviebase is not meant for Android TV OS, only regular mobile Android OS, that you won’t support it, etc. Well, all I can say is that I have umpteen other apps intended for phones, and they’re nothing I can’t handle between my air mouse and my utility to toggle portrait & landscape. I’ll admit you caught me with my pants down with the Connect to dialog’s UI glitch as hidden, but I’m not going to let that stand in my way, inasmuch as these things are only minor & cosmetic; the Android underneath the GUI is substantially the same. Hope you’ll continue to work with me, because SeriesGuide figures prominently in the set top box world, and I came to Moviebase in the first place seeking a substitute that’s not so awkward & un-intuitive to use (STB and phone)… So — any further ideas on my next step to proceed with my “You are offline” stumbling block connecting with Trakt?

Well, I guess my fears were not unfounded, and the developer dropped me like a hot potato because my problem is on a Shield box… I acquired my very first smart phone last week because my carrier said that my 3G flip phone would stop working at the end of the year due to the imminent shutdown of 3G. I installed Moviebase on the phone, and it connects to Trakt just fine without the “You are offline” error message, and it’s when the phone is using my same Wi-Fi network. But I still want to use Moviebase on my Shield because when I need to use Moviebase, I’m already on my Shield with airmouse in hand.

Can anybody get Moviebase to connect to Trakt on an Android TV box?